UbuntuUpdates.org

Package "gnome-desktop3"

Name: gnome-desktop3

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Introspection data for GnomeDesktop
  • Common files for GNOME desktop apps
  • Utility library for loading .desktop files - runtime files
  • Utility library for loading .desktop files - development files

Latest version: 3.32.1-1ubuntu1.2
Release: disco (19.04)
Level: updates
Repository: main

Links

Save this URL for the latest version of "gnome-desktop3": https://www.ubuntuupdates.org/gnome-desktop3



Other versions of "gnome-desktop3" in Disco

Repository Area Version
base main 3.32.1-1ubuntu1
security main 3.32.1-1ubuntu1.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 3.32.1-1ubuntu1.2 2019-07-11 00:08:04 UTC

  gnome-desktop3 (3.32.1-1ubuntu1.2) disco; urgency=medium

  * Cherry-pick patch from upstream to use mutter's connector-type to detect
    output connector type. This fixes suspend on some systems (primarily ones
    using the NVIDIA binary driver). (LP: #1731318)
  * libgnome-desktop-3-17.symbols: Update. The patch add two symbols and drops
    one. These symbols are defined in "gnome-rr-private.h", which is not
    shipped in the -dev package, so they can't be used in practice. This is a
    technical ABI break but one which it's OK to overlook. There's probably a
    better way to handle the visibility of these symbols, though.
  * debian/control*, gbp.conf: Update for ubuntu/bionic

 -- Iain Lane <email address hidden> Fri, 28 Jun 2019 13:34:02 +0100

Source diff to previous version
1731318 NVIDIA systems will not suspend with lid close and no external monitors

Version: 3.32.1-1ubuntu1.1 2019-05-27 14:06:20 UTC

  gnome-desktop3 (3.32.1-1ubuntu1.1) disco-security; urgency=medium

  * SECURITY UPDATE: thumbnailer sandbox escape via TIOCSTI
    - debian/patches/CVE-2019-11460.patch: fix incomplete TIOCSTI filtering
      in libgnome-desktop/gnome-desktop-thumbnail-script.c.
    - CVE-2019-11460

 -- Marc Deslauriers <email address hidden> Thu, 23 May 2019 12:45:04 -0400

CVE-2019-11460 An issue was discovered in GNOME gnome-desktop 3.26, 3.28, and 3.30 prior to 3.30.2.2, and 3.32 prior to 3.32.1.1. A compromised thumbnailer may esca



About   -   Send Feedback to @ubuntu_updates