UbuntuUpdates.org

Package "postgresql-11"

Name: postgresql-11

Description:

object-relational SQL database, version 11 server

Latest version: 11.5-0ubuntu0.19.04.1
Release: disco (19.04)
Level: security
Repository: main
Homepage: http://www.postgresql.org/

Links

Save this URL for the latest version of "postgresql-11": https://www.ubuntuupdates.org/postgresql-11


Download "postgresql-11"


Other versions of "postgresql-11" in Disco

Repository Area Version
base main 11.2-1
base universe 11.2-1
security universe 11.5-0ubuntu0.19.04.1
updates universe 11.5-0ubuntu0.19.04.1
updates main 11.5-0ubuntu0.19.04.1
PPA: Postgresql 11.3-1.pgdg14.04+1
PPA: Postgresql 11.5-1.pgdg16.04+1
PPA: Postgresql 11.5-1.pgdg18.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 11.5-0ubuntu0.19.04.1 2019-08-09 00:07:10 UTC

  postgresql-11 (11.5-0ubuntu0.19.04.1) disco-security; urgency=medium

  * SECURITY UPDATE: New upstream release (LP: #1839058)
    - Require schema qualification to cast to a temporary type when using
      functional cast syntax (CVE-2019-10208)
    - Fix execution of hashed subplans that require cross-type comparison
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when altering multiple
      columns' types in one command. This fixes a regression introduced in the
      most recent minor releases
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/11/static/release-11-5.html

 -- Christian Ehrhardt <email address hidden> Tue, 06 Aug 2019 08:56:03 +0200

Source diff to previous version
1839058 New upstream microreleases 9.5.19 10.10 and 11.5
CVE-2019-10208 postgres: Require schema qualification to cast to a temporary type when using functional cast syntax

Version: 11.4-0ubuntu0.19.04.1 2019-06-20 17:06:29 UTC

  postgresql-11 (11.4-0ubuntu0.19.04.1) disco-security; urgency=medium

   * New upstream release (LP: #1833211)
    - Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
      CVE-2019-10164
    - Fix assorted errors in run-time partition pruning logic
    - Fix possible crash while trying to copy trigger definitions to a
      new partition
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has a
      partial exclusion constraint
    - Fix failure of COMMENT command for comments on domain constraints
    - Prevent possible memory clobber when there are duplicate columns in a
      hash aggregate's hash key list
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/11/static/release-11-4.html

 -- Christian Ehrhardt <email address hidden> Tue, 18 Jun 2019 13:11:38 +0200

Source diff to previous version
CVE-2019-10164 postgres: Stack-based buffer overflow via setting a password

Version: 11.3-0ubuntu0.19.04.1 2019-05-13 13:07:27 UTC

  postgresql-11 (11.3-0ubuntu0.19.04.1) disco-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
      CVE-2019-10130
    - Avoid access to already-freed memory during partition routing error
      reports
      CVE-2019-10129
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/11/static/release-11-3.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:32 +0200

1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies
CVE-2019-10129 Memory disclosure in partition routing



About   -   Send Feedback to @ubuntu_updates