UbuntuUpdates.org

Package "libsoup2.4"

Name: libsoup2.4

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • GObject introspection data for the libsoup HTTP library
  • HTTP library implementation in C -- GNOME support library
  • HTTP library implementation in C -- GNOME support development files
  • HTTP library implementation in C -- Shared library

Latest version: 2.66.1-1ubuntu0.1
Release: disco (19.04)
Level: security
Repository: main

Links

Save this URL for the latest version of "libsoup2.4": https://www.ubuntuupdates.org/libsoup2.4



Other versions of "libsoup2.4" in Disco

Repository Area Version
base main 2.66.1-1
updates main 2.66.1-1ubuntu0.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.66.1-1ubuntu0.1 2019-10-09 19:06:54 UTC

  libsoup2.4 (2.66.1-1ubuntu0.1) disco-security; urgency=medium

  * SECURITY UPDATE: heap over-read in soup_ntlm_parse_challenge()
    - debian/patches/CVE-2019-17266.patch: avoid a potential heap buffer
      overflow in v2 authentication in libsoup/soup-auth-ntlm.c.
    - CVE-2019-17266

 -- Marc Deslauriers <email address hidden> Wed, 09 Oct 2019 10:34:56 -0400

CVE-2019-17266 libsoup through 2.68.1 has a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM mess



About   -   Send Feedback to @ubuntu_updates