UbuntuUpdates.org

Package "postgresql-10"

Name: postgresql-10

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • PL/Python procedural language for PostgreSQL 10
  • development files for PostgreSQL 10 server-side programming

Latest version: 10.9-0ubuntu0.18.10.1
Release: cosmic (18.10)
Level: security
Repository: universe

Links

Save this URL for the latest version of "postgresql-10": https://www.ubuntuupdates.org/postgresql-10



Other versions of "postgresql-10" in Cosmic

Repository Area Version
base main 10.5-1
base universe 10.5-1
security main 10.9-0ubuntu0.18.10.1
updates main 10.9-0ubuntu0.18.10.1
updates universe 10.9-0ubuntu0.18.10.1
PPA: Postgresql 10.8-1.pgdg14.04+1
PPA: Postgresql 10.9-1.pgdg16.04+1
PPA: Postgresql 10.9-1.pgdg18.04+1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 10.9-0ubuntu0.18.10.1 2019-06-22 13:06:53 UTC

  postgresql-10 (10.9-0ubuntu0.18.10.1) cosmic-security; urgency=medium

  * New upstream release (LP: #1828012)
    - Fix buffer-overflow hazards in SCRAM verifier parsing and libpq
      CVE-2019-10164
    - Fix failure of ALTER TABLE ... ALTER COLUMN TYPE when the table has
      a partial exclusion constraint
    - Fix failure of COMMENT command for comments on domain constraints
    - Prevent possible memory clobber when there are duplicate columns in
      a hash aggregate's hash key list
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-9.html

 -- Christian Ehrhardt <email address hidden> Tue, 18 Jun 2019 13:11:36 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10164 postgres: Stack-based buffer overflow via setting a password

Version: 10.8-0ubuntu0.18.10.1 2019-05-13 13:07:27 UTC

  postgresql-10 (10.8-0ubuntu0.18.10.1) cosmic-security; urgency=medium

  * New upstream release(s) (LP: #1828012)
    - Prevent row-level security policies from being bypassed via
      selectivity estimators.
      CVE-2019-10130
    - Details about these and many further changes can be found at:
      https://www.postgresql.org/docs/10/static/release-10-8.html

 -- Christian Ehrhardt <email address hidden> Tue, 07 May 2019 11:20:35 +0200

Source diff to previous version
1828012 New upstream microreleases 9.5.17, 10.8 and 11.3
CVE-2019-10130 Selectivity estimators bypass row security policies

Version: 10.6-0ubuntu0.18.10.1 2018-11-14 20:06:57 UTC

  postgresql-10 (10.6-0ubuntu0.18.10.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: Updated to 10.6 to fix security issue.
    - Details about the new release can be found at
      https://www.postgresql.org/docs/10/release-10-6.html
    - CVE-2018-16850

 -- Marc Deslauriers <email address hidden> Tue, 13 Nov 2018 14:20:49 -0500

CVE-2018-16850 postgresql before versions 11.1, 10.6 is vulnerable to a to SQL ...



About   -   Send Feedback to @ubuntu_updates