UbuntuUpdates.org

Package "libnm-util2"

Name: libnm-util2

Description:

network management framework (shared library)

Latest version: 1.12.4-1ubuntu1.1
Release: cosmic (18.10)
Level: security
Repository: universe
Head package: network-manager
Homepage: https://wiki.gnome.org/Projects/NetworkManager

Links

Save this URL for the latest version of "libnm-util2": https://www.ubuntuupdates.org/libnm-util2


Download "libnm-util2"


Other versions of "libnm-util2" in Cosmic

Repository Area Version
base universe 1.12.4-1ubuntu1
updates universe 1.12.4-1ubuntu1.2

Changelog

Version: 1.12.4-1ubuntu1.1 2018-11-05 15:07:01 UTC

  network-manager (1.12.4-1ubuntu1.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: buffer overflow in dhcp6 client
    - debian/patches/CVE-2018-15688.patch: make sure we have enough space
      for the DHCP6 option header in
      src/systemd/src/libsystemd-network/dhcp6-option.c.
    - CVE-2018-15688

 -- Marc Deslauriers <email address hidden> Fri, 02 Nov 2018 15:03:24 -0400

CVE-2018-15688 A buffer overflow vulnerability in the dhcp6 client of systemd allows a malicious dhcp6 server to overwrite heap memory in systemd-networkd. Affected



About   -   Send Feedback to @ubuntu_updates