UbuntuUpdates.org

Package "qtbase-opensource-src"

Name: qtbase-opensource-src

Description:

This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Qt 5 concurrent module
  • Qt 5 core module
  • Qt 5 D-Bus module
  • Qt 5 GUI module

Latest version: 5.11.1+dfsg-7ubuntu3.1
Release: cosmic (18.10)
Level: updates
Repository: main

Links

Save this URL for the latest version of "qtbase-opensource-src": https://www.ubuntuupdates.org/qtbase-opensource-src



Other versions of "qtbase-opensource-src" in Cosmic

Repository Area Version
base universe 5.11.1+dfsg-7ubuntu1
base main 5.11.1+dfsg-7ubuntu1
security universe 5.11.1+dfsg-7ubuntu3.1
security main 5.11.1+dfsg-7ubuntu3.1
updates universe 5.11.1+dfsg-7ubuntu3.1

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 5.11.1+dfsg-7ubuntu3.1 2019-06-03 17:07:24 UTC

  qtbase-opensource-src (5.11.1+dfsg-7ubuntu3.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: double-free or corruption via illegal XML document
    - debian/patches/CVE-2018-15518.patch: fix possible heap corruption in
      QXmlStream in src/corelib/serialization/qxmlstream_p.h.
    - CVE-2018-15518
  * SECURITY UPDATE: NULL pointer dereference in QGifHandler
    - debian/patches/CVE-2018-19870.patch: check for QImage allocation
      failure in src/plugins/imageformats/gif/qgifhandler.cpp.
    - CVE-2018-19870
  * SECURITY UPDATE: buffer overflow in QBmpHandler
    - debian/patches/CVE-2018-19873.patch: check for out of range image
      size in src/gui/image/qbmphandler.cpp.
    - CVE-2018-19873

 -- Marc Deslauriers <email address hidden> Mon, 25 Mar 2019 10:54:57 -0400

Source diff to previous version
CVE-2018-15518 QXmlStream in Qt 5.x before 5.11.3 has a double-free or corruption during parsing of a specially crafted illegal XML document.
CVE-2018-19870 An issue was discovered in Qt before 5.11.3. A malformed GIF image causes a NULL pointer dereference in QGifHandler resulting in a segmentation fault
CVE-2018-19873 An issue was discovered in Qt before 5.11.3. QBmpHandler has a buffer overflow via BMP data.

Version: 5.11.1+dfsg-7ubuntu3 2019-03-18 11:07:09 UTC

  qtbase-opensource-src (5.11.1+dfsg-7ubuntu3) cosmic; urgency=medium

  * Backport upstream commit to fix duplex printing (LP: #1776173).
    Thanks to Robert Bredereck for the initial patch!

 -- Dmitry Shachnev <email address hidden> Thu, 28 Feb 2019 13:26:39 +0300

Source diff to previous version
1776173 qt print dialog shipped with bionic ignores printer defaults

Version: 5.11.1+dfsg-7ubuntu2 2019-02-11 11:06:21 UTC

  qtbase-opensource-src (5.11.1+dfsg-7ubuntu2) cosmic; urgency=medium

  * Add a patch to pass default include directories to qdoc (LP: #1799111).

 -- Dmitry Shachnev <email address hidden> Fri, 02 Nov 2018 14:41:35 +0300

1799111 lots of Classes missing from docs (e.g. QFileInfo)



About   -   Send Feedback to @ubuntu_updates