UbuntuUpdates.org

Package "python-django"

Name: python-django

Description:

High-level Python web development framework (Python 2 version)

Latest version: 1:1.11.15-1ubuntu1.3
Release: cosmic (18.10)
Level: security
Repository: main
Homepage: http://www.djangoproject.com/

Links

Save this URL for the latest version of "python-django": https://www.ubuntuupdates.org/python-django


Download "python-django"


Other versions of "python-django" in Cosmic

Repository Area Version
base main 1:1.11.15-1ubuntu1
updates main 1:1.11.15-1ubuntu1.3

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 1:1.11.15-1ubuntu1.3 2019-07-01 15:07:11 UTC

  python-django (1:1.11.15-1ubuntu1.3) cosmic-security; urgency=medium

  * SECURITY UPDATE: Incorrect HTTP detection with reverse-proxy
    connecting via HTTPS
    - debian/patches/CVE-2019-12781.patch: made HttpRequest always
      trusty SECURE_PROXY_SSL_HEADER if set in django/http/request.py,
      docs/ref/settings.txt and added tests to tests/settings_test/tests.py.
    - CVE-2019-12781
  * SECURITY UPDATE: XSS in Django admin via AdminURLFieldWidget
    - debian/patches/CVE-2019-12308.patch: made AdminURLFieldWidget
      validate URL before rendering clickable link in
      django/contrib/admin/templates/admin/widgets/url.html,
      django/contrib/admin/widgets.py add test test/admin_widgets/tests.py.
    - CVE-2019-12308

 -- <email address hidden> (Leonidas S. Barbosa) Mon, 24 Jun 2019 13:28:11 -0300

Source diff to previous version
CVE-2019-12781 Incorrect HTTP detection with reverse-proxy connecting via HTTPS
CVE-2019-12308 An issue was discovered in Django 1.11 before 1.11.21, 2.1 before 2.1.9, and 2.2 before 2.2.2. The clickable Current URL value displayed by the Admin

Version: 1:1.11.15-1ubuntu1.2 2019-02-13 15:07:06 UTC

  python-django (1:1.11.15-1ubuntu1.2) cosmic-security; urgency=medium

  * SECURITY UPDATE: DoS via memory exhaustion
    - debian/patches/CVE-2019-6975.patch: limit digits in
      django/utils/numberformat.py, added tests to
      tests/utils_tests/test_numberformat.py.
    - CVE-2019-6975

 -- Marc Deslauriers <email address hidden> Tue, 12 Feb 2019 07:54:23 -0500

Source diff to previous version
CVE-2019-6975 Django 1.11.x before 1.11.19, 2.0.x before 2.0.11, and 2.1.x before 2.1.6 allows Uncontrolled Memory Consumption via a malicious attacker-supplied va

Version: 1:1.11.15-1ubuntu1.1 2019-01-09 19:07:19 UTC

  python-django (1:1.11.15-1ubuntu1.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: content spoofing in the default 404 page
    - debian/patches/CVE-2019-3498.patch: properly quote string in
      django/views/defaults.py, add test to tests/handlers/tests.py.
    - CVE-2019-3498

 -- Marc Deslauriers <email address hidden> Tue, 08 Jan 2019 13:37:05 -0500

CVE-2019-3498 Content spoofing possibility in the default 404 page



About   -   Send Feedback to @ubuntu_updates