UbuntuUpdates.org

Package "libssl1.1"

Name: libssl1.1

Description:

Secure Sockets Layer toolkit - shared libraries

Latest version: 1.1.1-1ubuntu2.4
Release: cosmic (18.10)
Level: proposed
Repository: main
Head package: openssl
Homepage: https://www.openssl.org/

Links

Save this URL for the latest version of "libssl1.1": https://www.ubuntuupdates.org/libssl1.1


Download "libssl1.1"


Other versions of "libssl1.1" in Cosmic

Repository Area Version
base main 1.1.1-1ubuntu2
security main 1.1.1-1ubuntu2.1
updates main 1.1.1-1ubuntu2.2

Changelog

Version: 1.1.1-1ubuntu2.4 2019-06-14 18:06:53 UTC

  openssl (1.1.1-1ubuntu2.4) cosmic; urgency=medium

  * Bump major version of OpenSSL in postinst to trigger services restart
    upon upgrade. Many services listed there must be restarted when
    upgrading 1.1.0 to 1.1.1. LP: #1832522
  * Fix path to Xorg for reboot notifications on desktop. LP: #1832421
  * Cherrypick upstream fix to allow succesful init of libssl and
    libcrypto using separate calls with different options. LP: #1832659

 -- Dimitri John Ledkov <email address hidden> Fri, 14 Jun 2019 13:27:38 +0100

Source diff to previous version
1832522 openssl maintainer scripts do not trigger services restart
1832421 openssl reboot needed message using incorrect path to X server
1832659 openssl 1.1.1-1ubuntu2.1~18.04.1 contains upstream bug 7350

Version: 1.1.1-1ubuntu2.3 2019-06-12 20:07:06 UTC

  openssl (1.1.1-1ubuntu2.3) cosmic; urgency=medium

  * Cherrypick upstream patch to fix ca -spkac output to be text again.
    LP: #1828215
  * Cherrypick upstream patch to prevent over long nonces in ChaCha20-Poly1305
    CVE-2019-1543

 -- Dimitri John Ledkov <email address hidden> Wed, 12 Jun 2019 00:09:23 +0100

1828215 openssl ca -spkac output regressed
CVE-2019-1543 ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for every encryption operation. RFC 7539 specifies that the nonce value (IV) s

Version: *DELETED* 2019-06-03 23:07:04 UTC
No changelog for deleted or moved packages.

Version: 1.1.1-1ubuntu2.2 2019-04-05 11:07:11 UTC

  openssl (1.1.1-1ubuntu2.2) cosmic; urgency=medium

  * debian/rules: Ship openssl.cnf in libssl1.1-udeb, as required to use
    OpenSSL by other udebs, e.g. wget-udeb. LP: #1822898

  * Drop debian/patches/UBUNTU-lower-tls-security-level-for-compat.patch
    to revert TLS_SECURITY_LEVEL back to 1. LP: #1822984

 -- Dimitri John Ledkov <email address hidden> Wed, 03 Apr 2019 20:37:01 +0100

1822898 wget https://geoip.ubuntu.com/lookup fails in mini.iso d-i
1822984 revert tls security level back to 1



About   -   Send Feedback to @ubuntu_updates