UbuntuUpdates.org

Package "ruby2.0"

This package belongs to a PPA: Brightbox Ruby NG Experimental

Name: ruby2.0

Description:

Interpreter of object-oriented scripting language Ruby

Latest version: 2.0.0.648-654bbox1~trusty1
Release: trusty (14.04)
Level: base
Repository: main

Links


Download "ruby2.0"


Other versions of "ruby2.0" in Trusty

Repository Area Version
base main 2.0.0.484-1ubuntu2
base universe 2.0.0.484-1ubuntu2
security main 2.0.0.484-1ubuntu2.13
security universe 2.0.0.484-1ubuntu2.13
updates main 2.0.0.484-1ubuntu2.13
updates universe 2.0.0.484-1ubuntu2.13

Packages in group

Deleted packages are displayed in grey.


Changelog

Version: 2.0.0.645-1bbox1~trusty1 2015-04-14 18:08:17 UTC

 ruby2.0 (2.0.0.645-1bbox1~trusty1) trusty; urgency=medium
 .
   * New upstream release, 2.0.0-p645

Source diff to previous version

Version: 2.0.0.643-1bbox1~trusty1 2015-04-07 20:08:53 UTC

 ruby2.0 (2.0.0.643-1bbox1~trusty1) trusty; urgency=medium
 .
   * New upstream release, 2.0.0-p643

Source diff to previous version

Version: 2.0.0.598-1bbox1~trusty3 2014-11-23 00:08:33 UTC

 ruby2.0 (2.0.0.598-1bbox1~trusty3) trusty; urgency=medium
 .
   [ Antonio Terceiro ]
   * New upstream snapshot.
   * Add patch by Yamashita Yuu to fix build against newer OpenSSL
     (Closes: #733372)
 .
   [ Christian Hofstaedtler ]
   * Use any valid Ruby interpreter to bootstrap
   * Bump Standards-Version to 3.9.5 (no changes)
   * Add myself to Uploaders:
   * Add Dependencies to facilitate upgrades from 1.8
     * libruby2.0 now depends on ruby2.0
     * ruby2.0 now depends on ruby
   * Stop installing alternatives/symlinks for binaries:
     * /usr/bin/{ruby,erb,testrb,irb,rdoc,ri}
 .
   [ John Leach ]
   * New upstream release
   * Includes fix for XML DoS (CVE-2014-8090)

733372 ruby2.0: FTBFS: ossl_ssl.c:2179:65: error: 'SSL_OP_MSIE_SSLV2_RSA_PADDING' undeclared (first use in this function) - Debian Bug report logs
CVE-2014-8090 Incomplete fix for CVE-2014-8080



About   -   Send Feedback to @ubuntu_updates