Package "surefire"

Name: surefire


This package is just an umbrella for a group of other packages, it has no description.
Description samples from packages in group:

  • Surefire test framework for Java

Latest version: 2.10-4
Release: precise (12.04)
Level: base
Repository: universe


Save this URL for the latest version of "surefire": http://www.ubuntuupdates.org/surefire

Other versions of "surefire" in Precise

No other version of this package is available in the Precise release.

Packages in group

Deleted packages are displayed in grey.



Version: 2.10-4 2012-03-30 15:07:00 UTC

surefire (2.10-4) unstable; urgency=low

  * Team upload.
  * Apply updated JUnit 4 detection patch. (Closes: #665796)
    - Thanks to James Page.

 -- tony mancill Mon, 26 Mar 2012 11:27:25 -0700

Source diff to previous version
665796 surefire: Surefire plugin fails with NPE for projects which don't depend on JUnit - Debian Bug report logs

Version: 2.10-2ubuntu2 2012-03-26 12:06:59 UTC

surefire (2.10-2ubuntu2) precise; urgency=low

  * d/patches/fix-junit-provider-selection.patch: Updated patch to deal
    maven projects which don't have any unit tests/don't depend on
    junit which caused a NPE (LP: #965061).

 -- James Page Mon, 26 Mar 2012 09:46:26 +0100

Source diff to previous version
965061 NullPointerException building maven projects which ...

Version: 2.10-2ubuntu1 2012-03-19 16:06:57 UTC

surefire (2.10-2ubuntu1) precise; urgency=low

  * d/patches/fix-junit-provider-selection.patch: Correctly detect 4.x
    version of JUnit from Debian Maven Repository so that JUnit47Provider
    is selected for execution of unit tests when appropriate (LP: #935219).

 -- James Page Mon, 19 Mar 2012 15:01:07 +0000

935219 libcommons-lang3-java version 3.0.1-1 FTBFS on i386...

Version: *DELETED* 2012-03-06 11:33:36 UTC
No changelog for deleted or moved packages.

Version: 2.10-2 2012-02-08 15:04:12 UTC

surefire (2.10-2) unstable; urgency=low

  [ Miguel Landaeta ]
  * Team upload.
  * Drop self Build-Depends on libsurefire-java. (Closes: #655011).
    Thanks to Daniel Schepler for the patch.

  [ Damien Raude-Morvan ]
  * Use Recommends: junit | junit4 | testng | libjmock-java instead of Depends
    as only one test framework is needed at a time. (Closes: #563710).

 -- Damien Raude-Morvan Sun, 08 Jan 2012 12:48:06 +0100

655011 surefire: Drop self-Build-Depends - Debian Bug report logs
563710 libsurefire-java: package dependencies should be suggestions - Debian Bug report logs

About   -   Send Feedback to @ubuntu_updates